elective-stereophonic
elective-stereophonic
Multigateway User Support Thread  
Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest Stable Nxt Client: Nxt 1.12.2

Pages: 1 ... 8 9 [10] 11 12 ... 83

Author Topic: Multigateway User Support Thread  (Read 240558 times)

VanBreuk

  • Hero Member
  • *****
  • Karma: +362/-19
  • Offline Offline
  • Posts: 2772
    • View Profile
Re: Multigateway User Support Thread
« Reply #180 on: August 17, 2014, 07:02:49 pm »

I didn't start using the MGW gateway prior to 1.2.5, which in my understanding has the new API. My deposit worked fine, which to me means the code still works with the 1.2.5 API.

The incompatibilities would happen at block 213,000, where DGS kicks in. Before that, no API changes are yet active.


I don't think that's true. The new API is in place now. I see the new API when I browse to http://localhost:7876/test and we are prior to block 213000.

Correct, sorry. The specific incompatibilities that would start at block 213,000 have to do with field names in the parsing of JSON objects, not the API changes specifically.
Logged
GPG Fingerprint: B020 D1C1 F289 3B2C 3577  9EAD 455D D175 5913 C7F1

PPan

  • Jr. Member
  • **
  • Karma: +0/-0
  • Offline Offline
  • Posts: 33
    • View Profile
Re: Multigateway User Support Thread
« Reply #181 on: August 17, 2014, 07:29:41 pm »

Unfortunately I cannot find the NXT Services menu.

NXT client 1.2.5
Ubuntu 13.04

ui files replaced (Lite_MGW_BETA_v1.4.1.zip)
server restarted

« Last Edit: August 17, 2014, 07:35:06 pm by PPan »
Logged

Pilot

  • Hero Member
  • *****
  • Karma: +47/-7
  • Offline Offline
  • Posts: 1241
    • View Profile
Re: Multigateway User Support Thread
« Reply #182 on: August 17, 2014, 07:36:57 pm »

Unfortunately I cannot find the NXT Services menu.

NXT client 1.2.5
Ubuntu 13.04

ui files replaced (Lite_MGW_BETA_v1.4.1.zip)
server restarted

Delete all the .gz files in the UI folder and subfolders.
Logged

PPan

  • Jr. Member
  • **
  • Karma: +0/-0
  • Offline Offline
  • Posts: 33
    • View Profile
Re: Multigateway User Support Thread
« Reply #183 on: August 17, 2014, 07:54:34 pm »

Unfortunately I cannot find the NXT Services menu.

NXT client 1.2.5
Ubuntu 13.04

ui files replaced (Lite_MGW_BETA_v1.4.1.zip)
server restarted

Delete all the .gz files in the UI folder and subfolders.

no success  ???
Logged

VanBreuk

  • Hero Member
  • *****
  • Karma: +362/-19
  • Offline Offline
  • Posts: 2772
    • View Profile
Re: Multigateway User Support Thread
« Reply #184 on: August 17, 2014, 08:02:30 pm »

I don't think the lingering .gz files should have any effect... My installation still has them and Nxt Services > MGW shows up in my Nxt Wallet nicely.

PPan, are you sure you unzipped Lte MGW in the correct path, overwriting /nxt/html/ui, and that you're running that install?
Logged
GPG Fingerprint: B020 D1C1 F289 3B2C 3577  9EAD 455D D175 5913 C7F1

PPan

  • Jr. Member
  • **
  • Karma: +0/-0
  • Offline Offline
  • Posts: 33
    • View Profile
Re: Multigateway User Support Thread
« Reply #185 on: August 17, 2014, 08:11:51 pm »

I don't think the lingering .gz files should have any effect... My installation still has them and Nxt Services > MGW shows up in my Nxt Wallet nicely.

PPan, are you sure you unzipped Lte MGW in the correct path, overwriting /nxt/html/ui, and that you're running that install?
Yes, I replaced /nxt/html/ui. What do you mean with "running that install" ?
After replacing the ui files I started nxt/run.sh
Logged

VanBreuk

  • Hero Member
  • *****
  • Karma: +362/-19
  • Offline Offline
  • Posts: 2772
    • View Profile
Re: Multigateway User Support Thread
« Reply #186 on: August 17, 2014, 08:20:26 pm »

I don't think the lingering .gz files should have any effect... My installation still has them and Nxt Services > MGW shows up in my Nxt Wallet nicely.

PPan, are you sure you unzipped Lte MGW in the correct path, overwriting /nxt/html/ui, and that you're running that install?
Yes, I replaced /nxt/html/ui. What do you mean with "running that install" ?
After replacing the ui files I started nxt/run.sh

I meant some of us might have different /nxt client folders (such as one set for testnet besides the main one) and accidentally modify the wrong folder.

It really should work.

- Stop 1.2.5 server
- Unzip http://multigateway.org/downloads/Lite_MGW_BETA_v1.4.1.zip in /nxt/html/ui, confirming overwrites.
- run that NRS 1.2.5
- wait until fully initialized - "Nxt server 1.2.5 started successfully"
- open http://localhost:7876, enter secret, see Nxt Services tab in left sidebar

Unless something is wrong in your NRS folder or you have permissions issues, it should work.
Logged
GPG Fingerprint: B020 D1C1 F289 3B2C 3577  9EAD 455D D175 5913 C7F1

eimon

  • Sr. Member
  • ****
  • Karma: +20/-4
  • Offline Offline
  • Posts: 290
    • View Profile
Re: Multigateway User Support Thread
« Reply #187 on: August 17, 2014, 08:31:49 pm »

1.2.5 is working for me in Ubuntu 14.04
Logged

PPan

  • Jr. Member
  • **
  • Karma: +0/-0
  • Offline Offline
  • Posts: 33
    • View Profile
Re: Multigateway User Support Thread
« Reply #188 on: August 17, 2014, 08:44:56 pm »

I meant some of us might have different /nxt client folders (such as one set for testnet besides the main one) and accidentally modify the wrong folder.

It really should work.

- Stop 1.2.5 server
- Unzip ... in /nxt/html/ui, confirming overwrites.
- run that NRS 1.2.5
- wait until fully initialized - "Nxt server 1.2.5 started successfully"
- open localhost:7876, enter secret, see Nxt Services tab in left sidebar

Unless something is wrong in your NRS folder or you have permissions issues, it should work.

That's how I did it, but no services entry ...
Are there any debugging options?
Logged

Pilot

  • Hero Member
  • *****
  • Karma: +47/-7
  • Offline Offline
  • Posts: 1241
    • View Profile
Re: Multigateway User Support Thread
« Reply #189 on: August 17, 2014, 08:47:30 pm »

Yes, your right. I just did the manual install on top of 1.2.6 on windows. It worked fine without deleting the .gz files. They MGW build must have been updated to .gz it's files. So, cool beans.

BUT: PPlan I still recommend you attempt to delete the .gz files and see if that resolves it.
Logged

PPan

  • Jr. Member
  • **
  • Karma: +0/-0
  • Offline Offline
  • Posts: 33
    • View Profile
Re: Multigateway User Support Thread
« Reply #190 on: August 17, 2014, 08:53:49 pm »

Yes, your right. I just did the manual install on top of 1.2.6 on windows. It worked fine without deleting the .gz files. They MGW build must have been updated to .gz it's files. So, cool beans.

BUT: PPlan I still recommend you attempt to delete the .gz files and see if that resolves it.

No change after deleting .gz files ...
Logged

VanBreuk

  • Hero Member
  • *****
  • Karma: +362/-19
  • Offline Offline
  • Posts: 2772
    • View Profile
Re: Multigateway User Support Thread
« Reply #191 on: August 17, 2014, 08:58:20 pm »

There's not really a debugging procedure since Lite MGW only involves changes in the html/ui files branch. You can check in the /nxt/html/ui you're running and verify that file sizes agree with the current version.

index.html for clean NRS 1.2.5 is 302,998 bytes
index.html for NRS modified with Lite MGW 1.4.1 extension is 329,935 bytes

I'm checking under Windows but file sizes should not differ between platforms.
Logged
GPG Fingerprint: B020 D1C1 F289 3B2C 3577  9EAD 455D D175 5913 C7F1

PPan

  • Jr. Member
  • **
  • Karma: +0/-0
  • Offline Offline
  • Posts: 33
    • View Profile
Re: Multigateway User Support Thread
« Reply #192 on: August 17, 2014, 09:47:41 pm »

There's not really a debugging procedure since Lite MGW only involves changes in the html/ui files branch. You can check in the /nxt/html/ui you're running and verify that file sizes agree with the current version.

index.html for clean NRS 1.2.5 is 302,998 bytes
index.html for NRS modified with Lite MGW 1.4.1 extension is 329,935 bytes

I'm checking under Windows but file sizes should not differ between platforms.

I installed the Windows version with the exe installer on win 8.1, the MGW is running as expected.
The files which the windows installer has created are exactly the same as my manually copied files on ubuntu.
The only difference is the used java version:
- The recent sun java runtime on windows
- OpenJDK 1.7.0_55 on ubuntu

Now I installed the Sun java runtime (jre1.7.0_67) on Ubuntu, but the same error as before: No Services entry.
Any ideas?

Edit: Starting the server as root has the same result, seems not to be a permission issue
« Last Edit: August 18, 2014, 06:04:52 am by PPan »
Logged

manrus

  • Jr. Member
  • **
  • Karma: +5/-6
  • Offline Offline
  • Posts: 53
    • View Profile
Re: Multigateway User Support Thread
« Reply #193 on: August 18, 2014, 02:04:53 pm »

When be first dividends ?
Logged

Sebastien256

  • Hero Member
  • *****
  • Karma: +169/-24
  • Offline Offline
  • Posts: 2823
  • ^LOOK UP^ = Nxt community!
    • View Profile
Re: Multigateway User Support Thread
« Reply #194 on: August 18, 2014, 02:05:58 pm »

When be first dividends ?

Good question. I would like to know too. Asset description is not very clear.
Logged
Please drop your ideas concerning Nxt and/or NRS in this topic -> List of feature request for Nxt and/or NRS (with the full list in OP).

valarmg

  • Hero Member
  • *****
  • Karma: +178/-57
  • Offline Offline
  • Posts: 1766
    • View Profile
Re: Multigateway User Support Thread
« Reply #195 on: August 18, 2014, 02:13:43 pm »

When be first dividends ?

Good question. I would like to know too. Asset description is not very clear.
From asset description:
"it also isnt designed to be a massive profit generator. Any investment in multigateway will help cover operating costs and help the NXT community"

I doubt that the MGW will be able to cover its costs until the InstantDex is up and running and has significant volume.
Logged
NXT-CSED-4PK5-AR4V-6UB5V

TwinWinNerD

  • Hero Member
  • *****
  • Karma: +222/-116
  • Offline Offline
  • Posts: 2012
  • CEO BitPanda.com
    • View Profile
Re: Multigateway User Support Thread
« Reply #196 on: August 18, 2014, 02:15:45 pm »

MGW asset will not get dividends from MGW trading.

Only when InstantDEX is enabled, it will pay dividends.

k3t3r

  • Jr. Member
  • **
  • Karma: +2/-0
  • Offline Offline
  • Posts: 53
    • View Profile
Re: Multigateway User Support Thread
« Reply #197 on: August 18, 2014, 05:20:10 pm »

is it possible to change the display settings so that the price of MGWbtc to NXT is displayed in BTC rather than mBTC?
« Last Edit: August 18, 2014, 05:23:31 pm by k3t3r »
Logged

k3t3r

  • Jr. Member
  • **
  • Karma: +2/-0
  • Offline Offline
  • Posts: 53
    • View Profile
Re: Multigateway User Support Thread
« Reply #198 on: August 18, 2014, 05:22:55 pm »

Basically I dont understand the pricing of mgwBTC on mgw. Current sell price of mgwBTC is 14,900

In the real world what does that figure represent?  ???
« Last Edit: August 18, 2014, 05:30:02 pm by k3t3r »
Logged

_mr_e

  • Hero Member
  • *****
  • Karma: +88/-18
  • Offline Offline
  • Posts: 956
    • View Profile
Re: Multigateway User Support Thread
« Reply #199 on: August 18, 2014, 05:30:35 pm »

is it possible to change the display settings so that the price of MGWbtc to NXT is displayed in BTC rather than mBTC?

It's displayed in Nxt which I will admit requires some weird mental math to figure out how to place your order and how much btc your paying. I wish this interface could be improved.
Logged
Pages: 1 ... 8 9 [10] 11 12 ... 83
 

elective-stereophonic
elective-stereophonic
assembly
assembly