elective-stereophonic
elective-stereophonic
NRS v1.8.2 singapore
Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest Nxt Client: Nxt 1.11.15

Pages: [1] 2 3 ... 5  All

Author Topic: NRS v1.8.2  (Read 22853 times)

Jean-Luc

  • Core Dev
  • Hero Member
  • *****
  • Karma: +816/-81
  • Offline Offline
  • Posts: 1610
    • View Profile
NRS v1.8.2
« on: April 18, 2016, 12:45:15 pm »

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Release 1.8.2

https://bitbucket.org/JeanLucPicard/nxt/downloads/nxt-client-1.8.2.zip

sha256:

742ee7d00001934f5855cc867d36fc752879c37ba8a68e276b90ff3f99f22123  nxt-client-1.8.2.zip

https://bitbucket.org/JeanLucPicard/nxt/downloads/nxt-client-1.8.2.sh

sha256:

8b9963155b30a897076ba8d2498ec96b287ca1928d6f2467d5a4fbe8ee8ba4e0  nxt-client-1.8.2.sh

https://bitbucket.org/JeanLucPicard/nxt/downloads/nxt-client-1.8.2.exe

https://bitbucket.org/JeanLucPicard/nxt/downloads/nxt-installer-1.8.2.dmg

The exe, dmg, and sh packages must have a digital signature by "Stichting NXT".


Change log:

This is a bugfix release. All users running 1.8.0e or 1.8.1 should upgrade.

Added html escaping of product names for marketplace recent listings.

Fixed marketplace listing for items without image.

Only show completed purchases in recent purchases.

Implemented import contacts for the desktop wallet UI.

Other minor UI improvements and bugfixes.

Allow absolute paths for keystore file location in nxt.keyStorePath property.


-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJXFM8wAAoJENqvaxkWiP4ZwSYQAKRFyGLWzmgp6q7oK+Wt1UuH
SnqmrcO4XSkwvMJ2jf43bwZttJi0ZAEwvd6RHQqc23+RAGKid4IdKA8BMwvbLsdE
DLV7aXts9dpmvdWxuRi64Bs491zivawN76+7GTqmezaJjL/msWxqNzF4as6pmOkV
LjABSM0N/gWsG0lz5oGi5Ts9/43P0UGdyvIPExPC90j5yDPCyDkGwU4aCcN6nohn
v/sjoqfH4dgqhNYQmqApw9n7RzdDBxsQWckgJ3BE6/NkPqG8qa6o/fy4vuH1Iqvf
O9EOUbiBJAUOISJcFdWW5hj59bsBCs8ydypMmyf8oGhN/4fheMNZ/c5JRhSbCIp8
MUia/o3e3aUcYe9XyiNqL4q5+xIBlqXELu5oz2FNaAXGYhWNfxNVNlSN6BfV1f/0
DTW8Nvb399Nz3vDPIc5KreoPz/nLx3rXjpTFzkL9VPnSjtO3j+mjr3Yyp6uWuA2m
KqM1THManvFpNOr5eX9eQUvZL0SGUgjhaB0EW0b70kvyZGT2NpH6/fl/k70nk5dR
aaZToXyL9vkYNBbG5oYwWMNlkTfTASyQjnoTLdT+hsrNnVPkEtsyntamQx0WiVUm
jMgjrHGVLMfxYi+HCRePdHISq1VK4w3ecq8CH/+2khEU/lsje/CWxNb2Zt3QMwSu
ZMHYxRmAqD4N9dAh4HM1
=iA14
-----END PGP SIGNATURE-----
Logged
GPG key fingerprint: 263A 9EB0 29CF C77A 3D06  FD13 811D 6940 E1E4 240C
NXT-X4LF-9A4G-WN9Z-2R322

yassin54

  • Hero Member
  • *****
  • Karma: +240/-14
  • Offline Offline
  • Posts: 2503
  • I am Homer, Sorry my english is Bad!!
    • View Profile
Re: NRS v1.8.2
« Reply #1 on: April 18, 2016, 01:29:52 pm »

NxtSwe

  • Hero Member
  • *****
  • Karma: +124/-9
  • Offline Offline
  • Posts: 657
    • View Profile
Re: NRS v1.8.2
« Reply #2 on: April 18, 2016, 01:36:24 pm »

When I go to the marketplace (in both chrome & edge, win 10) I get a popup saying "bug" in this new version.
Logged
Check out the NxtLib, the .NET Framework API for the Nxt platform.

abctc

  • Hero Member
  • *****
  • Karma: +148/-13
  • Offline Offline
  • Posts: 1396
    • View Profile
Re: NRS v1.8.2
« Reply #3 on: April 18, 2016, 01:44:01 pm »

Thank you!  2 nodes updated.
Logged
Welcome to the Nxt generation of crypto!   Magis quam Moneta (More than a Coin)
"Do not worry, it is an attack" (c) Jean-Luc

allwelder

  • Hero Member
  • *****
  • Karma: +196/-13
  • Offline Offline
  • Posts: 1867
  • NxtChina.org
    • View Profile
    • NxtChina.org
Re: NRS v1.8.2
« Reply #4 on: April 18, 2016, 01:49:24 pm »

Thanks.
Shared.
Logged
NxtChina |Weibo |Twitter Donation welcomed:NXT-APL9-66GU-K8LY-B3JJJ

qq2536007339

  • Hero Member
  • *****
  • Karma: +42/-9
  • Offline Offline
  • Posts: 514
    • View Profile
Re: NRS v1.8.2
« Reply #5 on: April 18, 2016, 01:56:53 pm »

Desktop application now show a error if there is no contacts.json file at C:\Users\username\AppData\Roaming\NXT when import contacts on win7.

Logged
你送我阿朵,我是要的。ARDOR-DJ68-PG7W-4JEU-2LU5T

testdruif

  • Full Member
  • ***
  • Karma: +71/-1
  • Offline Offline
  • Posts: 223
    • View Profile
Re: NRS v1.8.2
« Reply #6 on: April 18, 2016, 02:55:46 pm »

When I go to the marketplace (in both chrome & edge, win 10) I get a popup saying "bug" in this new version.

Can you show me a screenshot?
Logged
**Necessity is the mother of invention**
NXT-NNGD-V8TN-3MZR-DWWBE
https://arguseyes.net

Jean-Luc

  • Core Dev
  • Hero Member
  • *****
  • Karma: +816/-81
  • Offline Offline
  • Posts: 1610
    • View Profile
Re: NRS v1.8.2
« Reply #7 on: April 18, 2016, 03:16:30 pm »

Need to clear browser cache.

Those running shufflings, don't forget to restart your shufflers when you restart your node.
Logged
GPG key fingerprint: 263A 9EB0 29CF C77A 3D06  FD13 811D 6940 E1E4 240C
NXT-X4LF-9A4G-WN9Z-2R322

NxtSwe

  • Hero Member
  • *****
  • Karma: +124/-9
  • Offline Offline
  • Posts: 657
    • View Profile
Re: NRS v1.8.2
« Reply #8 on: April 18, 2016, 03:23:49 pm »

When I go to the marketplace (in both chrome & edge, win 10) I get a popup saying "bug" in this new version.

Can you show me a screenshot?
Not anymore, it was probably a cache related problem, thanx!
Logged
Check out the NxtLib, the .NET Framework API for the Nxt platform.

martismartis

  • Hero Member
  • *****
  • Karma: +73/-10
  • Offline Offline
  • Posts: 1237
    • View Profile
Re: NRS v1.8.2
« Reply #9 on: April 18, 2016, 08:27:11 pm »

Am I alone, noticing slower 1.8.2 performance? Getting a lot "Login timeout" exceptions. Or my raspi public node is used a lot from outside?
Logged

Riker

  • Core Dev
  • Hero Member
  • *****
  • Karma: +439/-42
  • Offline Offline
  • Posts: 1795
    • View Profile
Re: NRS v1.8.2
« Reply #10 on: April 18, 2016, 08:35:23 pm »

Desktop application now show a error if there is no contacts.json file at C:\Users\username\AppData\Roaming\NXT when import contacts on win7.

Right, the reason for this is the JavaFX webView does not support the Html5 File APIs.
Therefore the loading of contacts.json is executed by Java code.
But the Java code cannot detemine the location of the selected file to import using a browser file upload dialog.
Therefore the code assumes that contacts are always imported specifically from the file contacts.json placed in the platform dependent user home folder.
If the file does not exists, the message explains to the user where to place the file.
Logged
NXT Core Dev
Account: NXT-HBFW-X8TE-WXPW-DZFAG
Public Key: D8311651 Key fingerprint: 0560 443B 035C EE08 0EC0  D2DD 275E 94A7 D831 1651

CryptKeeper

  • Hero Member
  • *****
  • Karma: +78/-5
  • Offline Offline
  • Posts: 1235
    • View Profile
Re: NRS v1.8.2
« Reply #11 on: April 19, 2016, 12:30:50 pm »

The client 1.8.1 shows 4 update links under "NRS Update":
zipfile, windows, mac, linux.

Only the zipfile link downloads the 1.8.2 version, all the other links are still pointing to the 1.8.1 downloads.
Logged
Follow me on twitter for the latest news on bitcoin and altcoins!
Vanity Accounts Sale :-)

Riker

  • Core Dev
  • Hero Member
  • *****
  • Karma: +439/-42
  • Offline Offline
  • Posts: 1795
    • View Profile
Re: NRS v1.8.2
« Reply #12 on: April 19, 2016, 12:47:22 pm »

The client 1.8.1 shows 4 update links under "NRS Update":
zipfile, windows, mac, linux.

Only the zipfile link downloads the 1.8.2 version, all the other links are still pointing to the 1.8.1 downloads.

Fixed
Logged
NXT Core Dev
Account: NXT-HBFW-X8TE-WXPW-DZFAG
Public Key: D8311651 Key fingerprint: 0560 443B 035C EE08 0EC0  D2DD 275E 94A7 D831 1651

CryptKeeper

  • Hero Member
  • *****
  • Karma: +78/-5
  • Offline Offline
  • Posts: 1235
    • View Profile
Re: NRS v1.8.2
« Reply #13 on: April 19, 2016, 12:48:20 pm »

The client 1.8.1 shows 4 update links under "NRS Update":
zipfile, windows, mac, linux.

Only the zipfile link downloads the 1.8.2 version, all the other links are still pointing to the 1.8.1 downloads.

Fixed

You're a machine! Thanks!!!  :D  :D  :D
Logged
Follow me on twitter for the latest news on bitcoin and altcoins!
Vanity Accounts Sale :-)

Riker

  • Core Dev
  • Hero Member
  • *****
  • Karma: +439/-42
  • Offline Offline
  • Posts: 1795
    • View Profile
Re: NRS v1.8.2
« Reply #14 on: April 19, 2016, 01:02:39 pm »

The client 1.8.1 shows 4 update links under "NRS Update":
zipfile, windows, mac, linux.

Only the zipfile link downloads the 1.8.2 version, all the other links are still pointing to the 1.8.1 downloads.

Fixed

You're a machine! Thanks!!!  :D  :D  :D

No, I'm senile, I should have updated these when releasing 1.8.2, just forgot about it.
Thanks anyway.
Logged
NXT Core Dev
Account: NXT-HBFW-X8TE-WXPW-DZFAG
Public Key: D8311651 Key fingerprint: 0560 443B 035C EE08 0EC0  D2DD 275E 94A7 D831 1651

Klokan

  • Sr. Member
  • ****
  • Karma: +28/-5
  • Offline Offline
  • Posts: 286
    • View Profile
Re: NRS v1.8.2
« Reply #15 on: April 19, 2016, 09:23:07 pm »


It sounds like the TLS handshake is using an encryption algorithm that is not available.  The EC algorithms are part of the SunEC provider.  This provider is not shipped with OpenJDK.  Your debug log lists the TLS_ECDH_* algorithms as unavailable.  Take a look at https://bugzilla.redhat.com/show_bug.cgi?id=1167153.  There are some suggestions on how to overcome this problem.  Also http://stackoverflow.com/questions/31971499/ecdhe-cipher-suites-not-supported-on-openjdk-8-installed-on-ec2-linux-machine.

I don't know why it works with Nxt 1.7 and not with Nxt 1.8.  My guess is the different Jetty versions are the cause.  You could try replacing the jetty-* and websocket-* libraries in Nxt 1.8 with the libraries from Nxt 1.7 and see if that corrects the problem.

Yep, ScripterRon, you win the bet ;-). I tested it and -- websocket it's not necessary to replace (newer websocket-*9.3.8*jar files works as good as older websocket-*9.3.6*jar files), but jetty-*.jar files are the issue! When I replace the current 9.3.8 by the 9.3.6 older ones, everything starts to work well (as before).

So, many thanks, and a final question - would it be possible to repair it in 1.8.2 NRS version, or you cannot edit/fix in jetty jar files (almost) anything ?
No, we can't change the Jetty files. And Jetty might  not consider this a bug since they removed less secure ciphers in favor of the EC ciphers (which are more secure). If you can't install the EC ciphers on your system, you can try enabling the old ciphers. There is a nxt property to specify the ciphers to be used. Unfortunately, I don't remember the name and I'm out of town and can't look at the code. If you look in nxt-default.properties, you will see a list of ciphers commented out. Copy this list to nxt.properties, uncomment it and add the missing ciphers. Hopefully, this will allow Jetty to select the cipher that you need.

Allright, thank's for the suggestion, I switched on "org.eclipse.jetty.util.ssl.level=FINE" in logging.properties in one 1.7.5 NRS, and one "fresh new" 1.8.2 .

Then I grabbed "selected ciphers" output and did a diff among them. Here is the result :

Code: [Select]
2,7d1
< TLS_RSA_WITH_AES_256_CBC_SHA256
< TLS_DHE_RSA_WITH_AES_256_CBC_SHA256
< TLS_DHE_DSS_WITH_AES_256_CBC_SHA256
< TLS_RSA_WITH_AES_256_CBC_SHA
< TLS_DHE_RSA_WITH_AES_256_CBC_SHA
< TLS_DHE_DSS_WITH_AES_256_CBC_SHA
11,12d4
< TLS_RSA_WITH_AES_128_CBC_SHA
< TLS_DHE_RSA_WITH_AES_128_CBC_SHA
14,16d5
< TLS_RSA_WITH_AES_256_GCM_SHA384
< TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
< TLS_DHE_DSS_WITH_AES_256_GCM_SHA384
20,21d8
< SSL_RSA_WITH_3DES_EDE_CBC_SHA
< SSL_DHE_RSA_WITH_3DES_EDE_CBC_SHA

So, more algorithms/variants are in 1.7.5 version. Well, I got these ciphers from "diff output" and put them into nxt.properties, section nxt.apiSSLCiphers= (in the 1.8.2 NRS, of course). Result of this is really interesting - Firefox still doesn't work, as before, but Chrome, which worked before (just with warning), also doesn't work - until I commented these lines in nxt.apiSSLCiphers= section. Really weird...
Logged

ScripterRon

  • Hero Member
  • *****
  • Karma: +75/-2
  • Offline Offline
  • Posts: 523
    • View Profile
Re: NRS v1.8.2
« Reply #16 on: April 20, 2016, 02:22:38 pm »

Allright, thank's for the suggestion, I switched on "org.eclipse.jetty.util.ssl.level=FINE" in logging.properties in one 1.7.5 NRS, and one "fresh new" 1.8.2 .

Then I grabbed "selected ciphers" output and did a diff among them. Here is the result :

Code: [Select]
2,7d1
< TLS_RSA_WITH_AES_256_CBC_SHA256
< TLS_DHE_RSA_WITH_AES_256_CBC_SHA256
< TLS_DHE_DSS_WITH_AES_256_CBC_SHA256
< TLS_RSA_WITH_AES_256_CBC_SHA
< TLS_DHE_RSA_WITH_AES_256_CBC_SHA
< TLS_DHE_DSS_WITH_AES_256_CBC_SHA
11,12d4
< TLS_RSA_WITH_AES_128_CBC_SHA
< TLS_DHE_RSA_WITH_AES_128_CBC_SHA
14,16d5
< TLS_RSA_WITH_AES_256_GCM_SHA384
< TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
< TLS_DHE_DSS_WITH_AES_256_GCM_SHA384
20,21d8
< SSL_RSA_WITH_3DES_EDE_CBC_SHA
< SSL_DHE_RSA_WITH_3DES_EDE_CBC_SHA

So, more algorithms/variants are in 1.7.5 version. Well, I got these ciphers from "diff output" and put them into nxt.properties, section nxt.apiSSLCiphers= (in the 1.8.2 NRS, of course). Result of this is really interesting - Firefox still doesn't work, as before, but Chrome, which worked before (just with warning), also doesn't work - until I commented these lines in nxt.apiSSLCiphers= section. Really weird...
Jetty has a list of default ciphers which are used when the application doesn't specify any ciphers.  When you specify nxt.apiSSLCiphers, this replaces the default Jetty list with the supplied list.  When you added the missing ciphers, did they show up in nxt.log for NRS 1.8 (the servers logs the ciphers being used when the API server starts.

I'll see if I can spin up a virtual machine using OpenJDK 8 and try to connect to it.
« Last Edit: April 20, 2016, 02:38:51 pm by ScripterRon »
Logged

ScripterRon

  • Hero Member
  • *****
  • Karma: +75/-2
  • Offline Offline
  • Posts: 523
    • View Profile
Re: NRS v1.8.2
« Reply #17 on: April 20, 2016, 04:33:49 pm »

I set up an Ubuntu 15.10 system with OpenJDK (sudo apt-get install openjdk-8-jdk)
Code: [Select]
java -version
openjdk version "1.8.0_66-internal"
OpenJDK Runtime Environment (build 1.8.0_66-internal-b17)
OpenJDK 64-Bit Server VM (build 25.66-b17, mixed mode)
I am able to connect using Firefox on Ubuntu and Chrome on Windows 10.

However, the EC ciphers are available:
Code: [Select]
2016-04-20 12:10:47 FINE: API.lambda$static$164: API SSL Protocols: [TLSv1, TLSv1.1, TLSv1.2]
2016-04-20 12:10:47 FINE: API.lambda$static$164: API SSL Ciphers: [TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384, TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384, TLS_RSA_WITH_AES_256_CBC_SHA256, TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384, TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384, TLS_DHE_RSA_WITH_AES_256_CBC_SHA256, TLS_DHE_DSS_WITH_AES_256_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA, TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA, TLS_DHE_DSS_WITH_AES_256_CBC_SHA, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA256, TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256, TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256, TLS_DHE_RSA_WITH_AES_128_CBC_SHA256, TLS_DHE_DSS_WITH_AES_128_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA, TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA, TLS_DHE_DSS_WITH_AES_128_CBC_SHA, TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384, TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256, TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384, TLS_RSA_WITH_AES_256_GCM_SHA384, TLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384, TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384, TLS_DHE_RSA_WITH_AES_256_GCM_SHA384, TLS_DHE_DSS_WITH_AES_256_GCM_SHA384, TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, TLS_RSA_WITH_AES_128_GCM_SHA256, TLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256, TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256, TLS_DHE_RSA_WITH_AES_128_GCM_SHA256, TLS_DHE_DSS_WITH_AES_128_GCM_SHA256, TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHA, TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA, SSL_DHE_DSS_WITH_3DES_EDE_CBC_SHA, TLS_EMPTY_RENEGOTIATION_INFO_SCSV]
2016-04-20 12:10:47 INFO: API.lambda$static$164: Started API server at 0.0.0.0:7876, 0.0.0.0:7877
Perhaps you just need to install the latest OpenJDK. 
Logged

ScripterRon

  • Hero Member
  • *****
  • Karma: +75/-2
  • Offline Offline
  • Posts: 523
    • View Profile
Re: NRS v1.8.2
« Reply #18 on: April 20, 2016, 05:32:35 pm »

I also tried this using Ubuntu 14.04.  OpenJDK 8 isn't in the official repositories but you can get it from Launchpad:
  sudo add_apt_repository ppa:openjdk-r/ppa
  sudo apt-get update
  sudo apt-get install openjdk-8-jdk

The version is:
  openjdk version "1.8.0_72-internal"
  OpenJDK Runtime Environment (build 1.8.0_72-internal-b15)
  OpenJDK 64-Bit Server VM (build 25.72-b15, mixed mode)
Logged

Klokan

  • Sr. Member
  • ****
  • Karma: +28/-5
  • Offline Offline
  • Posts: 286
    • View Profile
Re: NRS v1.8.2
« Reply #19 on: April 20, 2016, 09:40:47 pm »

I set up an Ubuntu 15.10 system with OpenJDK (sudo apt-get install openjdk-8-jdk)
Code: [Select]
java -version
openjdk version "1.8.0_66-internal"
OpenJDK Runtime Environment (build 1.8.0_66-internal-b17)
OpenJDK 64-Bit Server VM (build 25.66-b17, mixed mode)
I am able to connect using Firefox on Ubuntu and Chrome on Windows 10.

However, the EC ciphers are available:
Code: [Select]
2016-04-20 12:10:47 FINE: API.lambda$static$164: API SSL Protocols: [TLSv1, TLSv1.1, TLSv1.2]
2016-04-20 12:10:47 FINE: API.lambda$static$164: API SSL Ciphers: [TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384, TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384, TLS_RSA_WITH_AES_256_CBC_SHA256, TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384, TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384, TLS_DHE_RSA_WITH_AES_256_CBC_SHA256, TLS_DHE_DSS_WITH_AES_256_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA, TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA, TLS_DHE_DSS_WITH_AES_256_CBC_SHA, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA256, TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256, TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256, TLS_DHE_RSA_WITH_AES_128_CBC_SHA256, TLS_DHE_DSS_WITH_AES_128_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA, TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA, TLS_DHE_DSS_WITH_AES_128_CBC_SHA, TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384, TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256, TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384, TLS_RSA_WITH_AES_256_GCM_SHA384, TLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384, TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384, TLS_DHE_RSA_WITH_AES_256_GCM_SHA384, TLS_DHE_DSS_WITH_AES_256_GCM_SHA384, TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, TLS_RSA_WITH_AES_128_GCM_SHA256, TLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256, TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256, TLS_DHE_RSA_WITH_AES_128_GCM_SHA256, TLS_DHE_DSS_WITH_AES_128_GCM_SHA256, TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHA, TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA, SSL_DHE_DSS_WITH_3DES_EDE_CBC_SHA, TLS_EMPTY_RENEGOTIATION_INFO_SCSV]
2016-04-20 12:10:47 INFO: API.lambda$static$164: Started API server at 0.0.0.0:7876, 0.0.0.0:7877
Perhaps you just need to install the latest OpenJDK.

Thanks for your time and research, ScripterRon. I'm using Fedora (not Ubuntu) on (some of) my servers, and I assume there (in last F23) the "eighth" OpenJDK already is :

Code: [Select]
java-1.8.0-openjdk-1.8.0.77-1.b03.fc23.x86_64
java-1.8.0-openjdk-headless-1.8.0.77-1.b03.fc23.x86_64
java-1.8.0-openjdk-devel-1.8.0.77-1.b03.fc23.x86_64

Actually, I'm not exactly sure, if this numbering of RPMs is corresponding with OpenJDK 8 (I guess it does, according to `java -version' it's newer than your version in Ubuntu 15.10), I'll make some "deeper research" about this in a while...

Thanks again !
Logged
Pages: [1] 2 3 ... 5  All
 

elective-stereophonic
elective-stereophonic
assembly
assembly